Prepomax options in v 2.0 vs older versions

Ok, having some interesting things with prepomax 2.0.0. I am following a tutorial:

PrePoMax (CalculiX FEA) - Tutorial 32 - Pressure imported from CFD (with OpenFOAM and FreeCAD) (youtube.com)

and in my version of prepomax, i do not have the ability to select “time” from the menu. Look at 17:56 of the video, maybe a few seconds before that. My CFDOF did not create folders for the time stamps… reconstructPar was added to the file

Second, in the video, the pressure is sclaed by 1.2 but i do not have that option. The only scale factor i have is for geometry. Unless magnitude factor is now the scale factor.

when i hit ok, it says the openfoam has no results hahaha. I do know it finished successfully because paraview can open it


image

thanks

There have been some changes in the settings of the Imported pressure load since then. Now you have the Magnitude factor to scale the pressure value.

You need a dummy .foam file to read the results, as shown in the video.

1 Like

Correct and i do have the dummy file, but for some reason it has no results according to prepomax. When 8 try to load the dummy file, it errors out and brings up that message.

Its also odd that yhe only time stamp folder i have is 0. Does the newer versions of open foam still make the time folders?

Thanks :slight_smile:

If the reconstructPar command didn’t work when set up before the simulation for some reason (maybe a typo or something), you can still use the OpenFOAM command prompt, navigate to that folder and use the same command from there on the existing results. It should create the timestamp folders outside of the processor ones.

1 Like

would not having the time stamp folders cause the “does not contain results” error?

I might just redo the entire tutorial again. I am on a laptop and so maybe something in the background caused an issue. But i will try it again : ) ill update you today at somepoint.

yeah, still not making the time directories. so something is missing that i can not see. And the new run still wont load in prepomax either

from paraview

image

It seems that you’ve resolved it already: Paraview loads empty state file after saving it - FreeCAD Forum

It is not resolved, it doesnt load in prepomax at all. Same error. It loads fine in para view but not prepomax. As shown above, there are no time directories created from cfdof even when using the reconstructPar command.

Prepomax, as soon as i load the dummy file, will show the error “no results” but clearly that is incorrect because para view shows them

PrePoMax reads the results mesh cells and the selected results field variable. Can you share the entire folder where your dummy file is?

In the photo above, that is the folder that contains all the information from my solver run. I can take a better screenshot soon when im home : )

Thanks

I guess that Matej meant whether you could share (attach) the files. It’s hard to diagnose issues based only on screenshots.

1 Like

ok, here is the files as per requested. They are on google drive due to how large it is. 157MB

the pv.foam dummy file is there.

https://drive.google.com/drive/folders/1aPez1EKr_ulAGEvxEQzvyv8sofZYciMf?usp=sharing