Issues with .inp file - Crashes 9 out of 10 times

Hi !

I’m currently working on a script that basically re-writes FreeCAD’s .inp file to include some specific functionalities of CalculiX that FreeCAD’s UI doesn’t support yet (netgen with refinement, elastic materials, axisymmetric simulations, bla bla bla).

The script itself works well but I’m getting a strange behavior from CalculiX (running with CalculiX’s latest public build). Let’s say I run my simulation 10 times. The simulation won’t start in 9 out of 10 cases and will run+successfully finish fully in the last case. The results themselves are really convincing.
The wrong outputs are always one of these:

  • “*ERROR in usermpc: mpc of type is unknown” which leads to an error thrown and stops simulation ofc
  • “Error() PySide2.QtCore.QProcess.ProcessError.Crashed” which leads to a “CalculiX done without error” even though nothing ran

I tried running from the command line and from FreeCAD’s interface and I get the same behavior/error (PySide2 crash doesn’t seem to happen from command line)

The current .inp file structure is inspired by how PrePoMax writes his.

I cannot attach my .inp file, so here’s a framapad from which you can copy and try it: Framapad mensuel. What could be the reason for these crashes ? Been working with CalculiX for some months now and it’s amazingly stable and i’ve gotten accustomed to the repeatability of its simulations ; which is why this behavior stands out even more.

Any hint/idea is much appreciated !

Best

I can’t confirm those crashes. When I run this input file with ccx 2.21 on Windows, it just doesn’t converge at some point (in some runs it fails to converge around 42% while in other it reaches 83% or even converges):

*ERROR: increment size smaller than minimum

As a side note, I would avoid those spaces between keywords. If you try to run this in Abaqus, it will throw errors about it. Speaking about that, I submitted this file in Abaqus and it reached 81% before failing to converge.

So for now, I only see the need to improve the model a bit in terms of convergence. Maybe remesh.

2 Likes

this line:

ConstraintDisplacement001,6

has to be removed.