Failure importing section, static mechanical analysis

Hello everyone! I am new to the CCX community but so far I love it. I’m currently working on an automated script for simulating mechanical response (simple compression test) of 3D printed lattices. I’ve been able to generate the structures in a separate software and import elements, nodes, BC’s, etc. However, I am consistently receiving the following Error when I import into PrePoMax:

“Error: Failed to import section: *SOLID SECTION, ELSET=ALL_NODES, MATERIAL=MAT_FIG4_TGH_15”

I’m assigning the material to the entire lattice, so the section is simply all elements. I’m using python to modify and compile the .inp file from the secondary software, so I thought it was an issue with my code. However, I tried creating the section from within PrePoMax, then exporting a .inp, then re-importing that same .inp and I receive the same error.

I can attach my .inp input file example if that is helpful. I appreciate any help that could be provided on this!

Can you say which software you are using for mesh preparation ? Is it Abaqus ?

I’m using nTopology, which is able to output .inp but it needs some slight modifications before using like replacing " " with “_” in certain places

1 Like

check if you can import it with cgx

Ok I’ll give it a shot, here’s a link to .inp if helpful: Lattice_07_20231005.inp - Google Drive

It might be better to prepare the geometry in nTopology, export it to STL or STEP and mesh in Gmsh for use in CalculiX.

Hi Jpel32 and welcome.
a quick note that caught my attention


Elset is intended for elements.
¿ALL_NODES, is a set of elements or nodes?

nset not according to input deck rules, the manual reads:

First line:
• Enter any needed parameters and their values.
Following line if the GENERATE parameter is omitted:
• List of nodes and/or sets of nodes previously defined to be assigned to this
node set (maximum 16 entries per line).

cgx shows the error when reading.

Thank you for looking at my file! Which line do you see “ELEST=ALL_NODES” in ?

Hmm that may be the issue. When I was printing the nodesets from python I don’t think I specified 16 per line. I’ll try that and then see what happens, thanks for the advice!

It’s right here in your first post:

@Calc_em Oh I see. I may have had an older file open when I copied the error message. This is what is reads now:
Where ALL_ELEMENTS is just all of the elements.

@JuanP74 I edited my script to output 16 entries max, but am recieving the same error in PrePoMax. Here is the updated .inp file. Lattice_04_20231005.inp - Google Drive

I appreciate everyones help!

it works in cgx. I have experienced some issues from prepomax when reading input files. You could try asking in prepomax discourse forum


The inp file importer in PrePoMax still needs some improvements, it doesn’t support all the different forms of mesh definition syntax permitted by CalculiX. It’s a known issue though.

1 Like

@Jpel32 , It seems like that PrePoMax ver. 1.3.4 and probably also newer versions are capable of loading your structure without errors

@fgr Interesting, I am using v1.4.1. I will maybe try 1.3.4 and see what happens

@fgr @Calc_em @JuanP74 @Disla
I attempted to open the .inp file in v1.4.0 and it worked, seems as though it was an issue with the newer 1.4.1 version. Thank you everyone for your help!

1 Like