Still problem in memory alloc

Dear Calculix Support, I have updated the Pardiso Solver for run my Thermo-Structural Analysis but it seems that the allocation memory issue is still there. Here below is reported the error message:

" Determining the structure of the matrix:
Using up to 1 cpu(s) for setting up the structure of the matrix.
number of equations
number of nonzero lower triangular matrix elements

*ERROR in u_calloc: error allocating memory
variable=xstateini, file=nonlingeo.c, line=833, num=1122431908, size=8

Job failed - no results exist.

Process elapsed time: 61.881 s

Aren’t you using parallel processing ? Which version of CalculiX ? Did you try reducing the mesh density ?

I’m submitting the job on a laptop, probably it work on more than 1 cpu. Calculix version is those related to 1.3.5 Prepomax. I’m working on a benchmark for comparison with Abaqus, so I can’t modifiy the mesh density because this will affect the results for the final scope that is the comparison.

Thanks & Regards

Check how many CPUs you have (Task Manager → Performance) and enter that number in Tools → Settings → CalculiX → Number of processors in PrePoMax.

check out this thread, maybe you need to use CCX i8 version

Can you share the model? I want to run it and check with gdb…

I tried with the maximum CPU (8) but still same error

Sorry, could yo explain better what you mean, I tried with the version named CalculiX Version 2.20.

No unfortunatelly I can’t share this model outside my organization. What you mean for check with gdb?

Could you reference the benchmark?. Is it based on some Abaqus validation file?
Have you been able to solve with a smaller mesh. Just to discard a problem on the *inp set up.?

No is it an internal Benchmark for compare the results between the two solver. Thanks for the suggestion, I’ll check with the reduction of the size model in order to fix the issue.

Its GNU’s debugger

sorry, I missed the link: Error allocating memory