Libgfortran5 for ccx2.21


I am very new to Calculix, and have been doing my best to run some of the example problems.

I can run GraphiX fine, but I cannot run the solver, as it requires libgfortran4. I am using a newer version of Ubuntu, so I can only get libgfortran5 which doesn’t appear to work with version 2.21.

Has anybody else experienced this problem? If so, what steps did you take to fix it?

Thank you very much!


Hi @tspencer95 , you can always try to install a previous version of fortran: How can I use two instances of-gfortran?


I have the same issue. I could not find a solution…

Same issue as well. libgfortran5 is already installed and can’t install libgfortran4 through ‘apt install’. I also resort back to using ccx 2.17 for the moment.

Have you tried my installation script:

To run:

perl install


Thank you for this! Just installed and it works absolutely fine with your script.
And this video helped me to install the necessary Intel Fortran Compiler:

Any plans to also include installation with PaSTiX, as it seems to be the preferred option now?

Tried to get pastix to work a couple years ago but was unsuccessful. Got something working, but found it to be slower than pardiso. For some reason , it factors the matrix twice instead of once. Doesn’t seem to be actively maintained so kind of gave up on it. Maybe something has changed now?