How to use surface set in radiate boundary condition

Data line for keyword should be like:


According to the manual, “In order to apply radiation conditions to a surface the element set label underneath may be replaced by a surface name. In that case the “x” in the radiation flux type label is left out.”

But I tried the data line with surface name, in this format:


What was wrong?

The related files are at

Below your original line and then 3 alternatives which all worked on my side:

** original:
** works with Surface name:
** works with same results:
** using ELSET name instead of Surface name:

It only worked for me once I set in source file ini_cal.c the parameter nload_=100000, then recompiled and linked the source code.

I can not find any documentation on changing the value for “nload_”, what the meaning of a value of 100000? That should be the default. The element number and face number are already defined in the surface set definition, it is unnecessary to duplicate.

There may be no documentation on the nload_ variable in the official ccx manual. But at least ccx writes an error to the standard console output what you can do to overcome the (sizing) issue. ccx tells you which variable to change in which source file. Much better than nothing! As you I don’t have much an idea of what nload_ (default setting in the code is nload_ = 0) is being used for, but I got it technically working through the ccx instructions on the output screen.

There are many parameters in the ccx source code files being defined for the default sizing of vectors and matrices which should fit for the significant majority of models. Your model details may deviate a bit too much from standard sizing parameters why you are asked to adjust a given parameter.

By the way ccx has never been easier to compile than with the new version 2.21 even on Windows 10. With the standard Makefile you can now compile it without problems to run it with the Spooles solver.

I still think use of surface set should be default, it significantly simplifies the preprocessing.

According to the documentation, the element face number can be omitted if surface name is used, if so, this is a bug that the original is not working.

** original:

The error message for the original input:

 *ERROR reading *RADIATE. Card image:

your modification make the face number specific in Rx:

** works with Surface name:

but the convection surface has different face numbers, your end result is wrong.