Error, Pardiso Library not linked


I have a problem. I try to use Calculix with PARDISO solver (MKL Pardiso INTEL), because I get faster runtimes however when I run the same problem sometimes it runs correctly but most of the times I get this error:

*ERROR in nonlingeo: the PARDISO library is not linked

I do not understand how is it possible sometimes to complete and sometimes not. Maybe it is related with the convergence of the problem. Has anybody else faced this problem??

Thank you in advance!

Couple of wild guesses:

Maybe some MKL dlls are somewhere else and not always accessible because of PATH or the current directory you’re running CCX from or whatever?

Compare the build time shown near the beginning of the output to make sure it’s the exact same .exe and not sometimes picking up a different build because of PATH/etc.

1 Like

Hi, i have similar problem in the past and found some dll’s are missing.

please provide more detail in CalculiX versions, list of dll you’re using, and some test case available.

maybe another user of Pardiso solver could help to investigate and give some advised.

1 Like

Thanks for your replies!

I use Calculix 2.20 version and I have downloaded Intel Base and HPC toolkit. Also the dlls I use are:
And I have them all in the same folder with ccx.exe . I will return with a test case available. Thank you in advance for your help.

honestly i still use CalculiX 2.19 versions in Pardiso solver with 2021 MKL, below list of dll i used.

  • libiomp5md
  • mkl_avx2.1
  • mkl_avx512.1
  • mkl_core.1
  • mkl_intel_thread.1
  • mkl_mc3.1
  • mkl_rt.1

CalculiX 2.20 versions with 2022 MKL may slightly differs. even i’m not really sure with your problems, but i seen an avx and mc dll is missing.

maybe another user can clarify and give some advices.

1 Like

I tried also with your configuration (v 2.19) and in the first run I got very good results and then I had the same error. I have also detected a strange behavior. Let me give you some numbers in order to be more clear:
When I run with the default solver I get average 200 sec on my problem and it runs every time with no problem.
When I put in the .inp file SOLVER=PARDISO the first run Calculix produces the .frd file on average in 50sec but at the end it does not have the desired ‘9999’ to indicate the end. In the second run I get an .frd with only ‘1C’ in a few lines like that:
and in the third and fourth run I get correct results. However, after that I get .frd files like the one in the second run. And also the error Pardiso Library not linked is always there even at the 3rd and 4th runs. I describe these runs because it is a pattern, it is not random.
Thus, my question is how is it possible to run correctly on the 3rd and 4th runs and at the others not, and also with the error of not linked library to continue?
I use the ccx.exe to execute it, however when I use the ccx_dynamic.exe the same model does not seem to converge. I hope I did not make it more complicated.
Thank you!

1 Like

i"m using ccx_dynamic.exe instead, run and solving analysis cases with contact and plasticity. no issues in convergences and always getting consistent results when i rerunning an analysis.