CCX calculating eigenmode failure

Dr. Guido Dhondt:

I have used CCX 2.17 window version to do the modal analysis, it is failed due to the SPOOLES. look like:
Calculating the eigenvalues and the eigenmodes
1)prool debug output: C,A 0.0000000E+00 0.9007199E+16
prool debug output: C,A 0.9007199E+16 0.9007199E+16
prool debug output: C,QTR,LBETA 0.2000000E+01 0.2500000E+00 2
prool debug output: C LT A LBETA 0.1000000E+01 0 0.1000000E+01 2
prool debug output: C LT A LBETA 0.1000000E+01 1 0.2000000E+01 2
prool debug output: C LT A LBETA 0.1000000E+01 2 0.4000000E+01 2
prool debug output: C LT A LBETA 0.1000000E+01 3 0.8000000E+01 2

And I try to use the PARDISO solver, it also fail with “U^TMU=1.000000 for eigenmode 1”.

The modal analysis seems working fine for CCX 2.12.
Do you have any critical changes for the modal analysis module for the new version?



I remember a change between versions 2.15 and 2.16 (on Windows): With 2.15 I was able to calculate the eigenvalues of unconstrained structures, with 2.16 that no longer seemed to be possible. I then added some boundary conditions to suppress the rigid body motions (translations and rotations) and it worked again. So if you do not have boundary conditions applied that may be the next logical step to further analyze the failure of your job.

I have no problem with unconstrained eigenmodes with SPOOLES in CCX 2.16 or 2.17.

@zdong, I wonder if you could post a minimal version of your .inp files so we can try to isolate the problem?

Johanngil: I do have the constraints applied.
vicmw: How can I post the .inp file? It is pretty large.
Thanks for your replies.



If you try to run the ccx example, rotor.inp, it will fails.


i can reproduced your problems. yes PaStix solver fails to complete, throwing an error messages:

 Composing the complex eigenmodes from the real eigenmodes

 *INFO in complexfreq: if there are problems reading the .eig file this may be due to:
       1) the nonexistence of the .eig file
       2) other boundary conditions than in the input deck
          which created the .eig file

 *ERROR in complexfreq: the .eig-file was created with perturbation info
        the present *COMPLEX FREQUENCY step, however, does not contain the
        perturbation parameter on the *STEP card.

edited: previously i’m using input files for 2.13 versions, not a problems using latest (2.17) it may due to compatibility.


I ran the standard example file rotor.inp file on my Windows PC with 2.17 and found no issue:
The .dat files contains for both steps the respective 10 Eigenmode values

Adding the commands for cgx eigenmode visualization in rotor.inp as:

*el print,elset=Edisk,TOTALS=ONLY
*end step

U, S
*end step

*complex frequency,coriolis
U, S
*end step

I then verified in cgx if modes are seen and if they are reasonable. The included images seems to show a reasonable mode. So I don’t see an issue with this example and Calculix version 2.17.

Thanks. xyont.
I use my compiled CCX, it will failed. If I use the Dr. Guido site’s executable, it runs out OK with something like,
U^TMU=0.000000 for eigenmode 8
U^TMU=0.000000 for eigenmode 12
I don’t know what this means.


Yes. This example is OK for Dr. Guido site’s window executables with something like
U^TMU=0.000000 for eigenmode 0;But it still is failed with my compiled ccx in cygwin.
And I use the Dr. Guido site’s window executables to run my model, it just stops after starting spooles solver. I have not found any clue yet. Maybe it just is the compiling issue.