About run calculix with abaqus inp file

Hello friends.
Glad to meet you here!

I Just started calculix and have lots of problems… Plz help me.
I made inp file by abaqus and tried to run calculix with it. but its not working.
error message is ’

What should I do with this …

These are just warnings, errors are likely below so you have to scroll down. But I can already see that you use inp file with assembly definition. This is not supported in CalculiX so you have to select “Do not use parts and assemblies in input files” in Abaqus before exporting the input file. Some other changes will have to be done to this file to make it work in CalculiX but error messages should point you to them. The thing is that CalculiX uses almost the same keywords as Abaqus but not 100% the same - there are differences in some keywords, several keywords are not supported at all in CalculiX and so on. Use the Abaqus and CalculiX documentations to prepare the input files properly.

2 Likes

Hi Calc_em .
I thought they are using same keywords… and didnt know abaqus has that option
I tried to fix this problem for 2weeks now!! thank you very much !! I will try that.

I tried to export inp file without parts and assemblies but still not working.

At first glance: *MEMBRANE SECTION is available from 2.14 version (you have 2.11)

http://www.dhondt.de/ccx_2.13.pdf
vs
http://www.dhondt.de/ccx_2.14.pdf

First of all, delete the whole section with output requests because most keywords there are not compatible with CalculiX. Instead of that, place some standard request for CalculiX such as:

*Node File
U
*El file
S,E

Also, remove the Name parameter from the *Step keyword, delete the *Preprint keyword under the heading and the *System keyword. Those are not supported by CalculiX.

And use the newest CalculiX version - 2.19 or at least the previous one (2.18).

1 Like

I think I did what you have said… It did fix! but have another problem… (use 2.19 ver and fix all keywords)

Im very sorry… Im so stupid…I only have used starccm , abaqus on window.
if you have time can you look my ino file?

https://drive.google.com/drive/folders/1OumfcLotKJCpPp765gs6n-FUKhdUl_Qn

It looks like you used Node file and El file instead of Nset and Elset, respectively. If you fix this, replace the whole output requests block with what I specified in the previous post and add missing * to the first occurrence of “Step1”, the analysis will work.

Wow Thack you! Its working!!!
Can you up load inp file in my google drive???

1 Like

I uploaded the corrected file here:

1 Like

@Calc_em you are definitely a lifesaver!

1 Like