Substructure generation matrix with *Distributing Coupling

Hello all!
I’m trying to generate a substructure model but the matrix does not come out when I use *DISTRIBUTING COUPLING elements as the retained nodal DOFs- I use the node at the center of these elements. Has anyone experienced this behavior before? If I do not use the coupling element, then the matrix comes out fine.


Which version of CalculiX is that ? Distributing coupling was reworked in recent releases.

Version 2.19 and tried with SOLVER=SPOOLES and PASTIX. Same results.
I glanced at the source code for those cards and didn’t see anything that would raise questions. Not sure where to start for debugging in this case.

Have you tried the other way of defining distributing coupling constraints:



It looks like it is working for *COUPLING followed by *DISTRIBUTING. I will have to do a couple of tests to check the matrices and ensure everything is the same—no idea why it doesn’t work for the *DISTRIBUTING COUPLING element.

Distributing coupling elements can be quite problematic for substructure generation procedure but still, it shouldn’t work like that. Here’s how Abaqus handles it:

If any degrees of freedom of nodes used to define distributing coupling elements are retained, the degrees of freedom of an internal node associated with the Lagrange multipliers are added automatically to the list of the retained degrees of freedom of the substructure.

Too bad there’s no place to submit bug reports for CalculiX. Currently, bug reports tend to fade away in forum discussions.

1 Like

I use them all the time in Nastran/OptiStruct, and they work like a charm. So I thought the procedure behind the scenes was the same, MPC-constraints, and thus would be equivalent here in CalculiX.

Absolutely agree with this. @dhondt, are there have any plans to have a GitHub project for CalculiX? I noticed an archive project but not a current development project for users to submit this type of issue and potential workarounds.