PaStiX4CalculiX does not use GPU

Hello everyone,
I was able to compile calculix with pastix solver on Centos7.
But Pastix does not use nor see any nvidia GPU. Output on solving is:

  • PaStiX : Parallel Sparse matriX package     +

Version: 6.0.1
sequential: Enabled
thread static: Started
thread dynamic: Disabled
PaRSEC: Started
StarPU: Disabled
Number of MPI processes: 1
Number of threads per process: 12
Number of GPUs: 0
MPI communication support: Disabled
Distribution level: 2D( 128)
Blocking size (min/max): 1024 / 2048

Matrix type: General
Arithmetic: Float
Format: CSC
N: 126300
nnz: 10132848

I compiled PaStiX4CalculiX with from the calculix source tarball and edited CMakeLists.txt at:

GPU engine parameters

“Enable GPU support using CUDA kernels” ON)

Has anybody successfully used ccx+pastix on gpu?
How can I tell pastix to use the gpu?

Any help is appreciated.
Kind Regards, and thanks in advance

Maybe try changing the parameter for (in the console):
export PASTIX_GPU=1

pastix.c (line 790):

const char* pastix_gpu = getenv("PASTIX_GPU");
	gpu = (*pastix_gpu == '1') ? 1 : 0;

I didn’t recognize there was an environment variable PASTIX_GPU
It works, thank you very much!

But it works for real or just changed value: “Number of GPUs:”?

Yes it works because I’m getting a

[1] 29649 segmentation fault (core dumped) ./ccx_2.17_i8
at runtime (second increment) due to
Program terminated with signal SIGSEGV, Segmentation fault.
#0 0x0000000000e3381e in performLightLsMV ()

so I think it works (and I made a mistake while compiling…)