Layered shell (composite) with spring element

i try to modeling of layered shell (composite) S8R connected with spring element at edge faces, however it’s not working and throw some error message. these problem does not occurs with non composite shell element.

*ERROR in changekon: element type unknown: element: 32 type: ESPRNGA1

any hints or suggestion?

maybe you can post a very simple case ?
maybe only one shell element with spring element ?
wbr

i just experienced the same issue. if you work with springs on solids everything works fine. springs in shell modeling results in that error warning.

Can you share a sample file?

1 Like

while trying to recreate the issue → everything worked fine for that simple problem. so its not necessarily a general issue. i will look for other reasons, but the error warning is the same for me in my original modelling.

In my previous model, i placed the spring at the edge of shell element (layered).

Could you reproduce my problem?

there seems to be no connection between the error and the spring being placed on the edge of the shell. i just tested it and for both cases(on the edge and on not on the edge) i get the same error.

what element type of spring do you use? is the same using SPRINGA as original post

yes the linear spring model

Thanks for clarify, may this lead to a different problem since i activated nonlinear options in the previous model.

I’ll took back my time to study the problems with latest version of CalculiX.

Hi,

Maybe it helps.

I have run a laminate with springs and Static in different positions with ccx under Mecway and it gives the following error.

*ERROR in changekon: element type unknown: element: 337 type: ESPRNGA1

The description seems a mixture between SPRINGA and SPRING1. ?¿?

Element 337 is an *ELEMENT,TYPE=SPRINGA according to the INP generated by MECWAY.

The image corresponds to the solution with the internal solver.

imagen

No problems with Orthotropic or Laminate if only has 1 Layer.

May it’s right, as mention in the beginning of discussions. Not a problem for non composite (layered) shell element.

Screenshot by @paffins seems not tested for this point, shown no lines of layered shell. could it be clarified?

the model you are mentioning is a composite(layered shell). i havent tested it yet for non composites. but i can confirm that the same error occurs when truss elements are used instead of spring elements.

what i have experienced so far is that if you use composite with one layer it will work. if you use composite with more than one layer it wont work. if you use a noncomposite it will not work. it doesnt make a lot of sense but thats what ive experienced so far.

futhermore in your whole shell modelling there has to be ONLY one layered composites. if you have one face which has multiple shell layers even if it is not connected to a spring, the error will occur.

maybe is just a typo in the input deck which is somewhat tricky according to the manual:

it seems typo is not related to the problem, as mention before. the analysis ran properly for non composite (layered) shell element.

I modified the line about 111 in file changekon.f by the following and now seems to work (I just checked completes with no error):

     elseif((lakon(i)(1:7).eq.'SPRINGA').or.
 &      (lakon(i)(1:7).eq.'ESPRNGA')) then

source of confusion seems to lie in file elements.f

1 Like