I am seeing some strange CPRESS results

I have a model I have built that is giving me some strange CPRESS stresses, (my first proper Calculix model but I am coming for quite a bit of experience with Abaqus although it has been a couple years since used it every day)

This is created and post processed in PrePoMax, I have not tried to postprocess the results in any other software yet which should probably be my first step if I had anything else installed :slight_smile:

This is a cam/piston lock mechanism. It is basically an an offsent pin turns in a slot and drives a piston which moves linearly. It took a while to get the model running correctly but it does what I expect now although it is a bit large and takes 12 hours on my fairly powerful computer. (this is run 17 so I have been working on it off and on for a while :slight_smile: I forgot to request the reaction force on the rotation BC on the pin but will do that next time I run it.

The attached pictures show the issue. The cam pin is slightly (0,02mm smaller than the hole it is in) and I think I have contact adjustment turned off. At the step shown in these pictures there should be near zero load as the cam is just rotating a few degrees and is not yet touching the slot wall. If I plot load on the cam surface or load on the working end of the piston there is no real load at this point but I see these very high stresses all around the bearing ends of the cam pin.



Dear Luke,

it might be something wrong with the PrePoMax so post-processing in another software is the first step.

The other reason could be the mesh. When the mesh is created, the cylindrical surface it turned into a polygonal surface. For the solid cylinder, the polygonal surface is inscribed into a cylindrical surface making it smaller. Similar goes for the hole.

Did you use a node to surface or a surface to surface contact?

Thanks Matej
I used Surface to Surface interaction without adjustment.
The holes are 0,02mm over size (on a 10mm hole), perhaps I should have made the holes a bit larger.

I need to get my Linux machine and try some other post processing.